Mikrotik

Instalasi Sistem Operasi

Pada saat booting masuk ke setting BIOS . Kemudian pada setting boot sequences pilih pada first boot pada CD-ROM dan second pada IDE-0 [hdd]. Save settings kemudian restart [pastikan CD installer Mikrotik sudah ada di CD-ROM]. Booting dengan CD.   Saat booting kemudian masuk ke pilihan paket yg dapat diinstall.  Ilustrasinya sebagai berikut :

Welcome to MikroTik Router Software installation Move around menu using ‘p’ and ‘n’ or arrow keys, select with ‘spacebar’. Select all with ‘a’, minimum with ‘m’. Press ‘i’ to install locally or ‘r’ to install remote router or ‘q’ to cancel and reboot.

[X] system                                                      [X] advanced-tools

[X] isdn                                                            [X] radiolan

[X] synchronous                                          [X] web-proxy

[X] ppp                                                             [X]  arlan

[X] lcd                                                               [X] routerboard

[X] telephony                                                [X] wireless

[X] dhcp                                                           [X]  gps

[X] ntp                                                              [X] routing

[X]  ups                                                             [X] security

[X] hotspot

untuk memilih paket tekan spasi pada saat menyorot.  Anda akan ditanyakan 2 hal :

Warning: all data on the disk will be erased! Continue? [y/n] [tekan Y]  Press [Y] to continue or [N] to abort the installation.

Do you want to keep old configuration? [y/n]: [tekan Y] You should choose whether you want to keep old configuration (press [Y]) or to erase the configuration permanently (press [N]) and continue without saving it.

For a fresh installation, press [N]. [ tekan Y jika ingin konfigurasi awal disimpan tekan N untuk fresh Install,disini saya lebih memilih N] Creating partition… Formatting disk… The system will install selected packages. After that you will be prompted to press ‘Enter’. Before doing that, remove the CD from your CD-Drive: Software installed. Press ENTER to reboot

[edit] Konfigurasi User

Setelah reboot kita bisa login. Gunakan nama : ADMIN dengan password : <kosong>. Setelah masuk kita buat User Baru untuk menggantikan user admin.

[admin@mikrotik] > user add Name : [isi nama user] <ENTER> Group : full <ENTER>

Pilihan Group yang ada

full untuk admin

read untuk guest  Selanjutnya membuat password :

[admin@mikrotik] > user print

Akan tercetak daftar user

[admin@mikrotik] > user edit number : 1 [ sesuai nomor urut user anda]

value-name : pass

ketikkan password anda, kemudian tekan ctrl+O kemudian disable user admin.

[admin@mikrotik] > user disable admin

untuk memeriksa apakah sudah disable ketik

[admin@mikrotik] > user pr

Jika user admin terdapat tanda X disebelah kiri maka sudah ter-disable.

[edit] Konfigurasi Interface Selanjutnya, kita set interface :  Pertama kita check dulu interface terpasang.

[admin@mikrotik] > interface print

Untuk memudahkan dalam konfigurasi kita berikan nama unik untuk interface2 yg kita gunakan.

[admin@mikrotik] > interface edit Number : 1 Value name : name

Ganti ether2 dengan eth2-lokal [ ini untuk interface ke local client 192.168.0.0/16]

Tekan Ctrl+O

kemudian lakukan langkah yg sama untuk ether3 dan 4 dengan nama eth3-ADSL [ke ADSL] dan eth4-servers[ke switch PC server].  Kemudian buat satu interface bridge baru [sebagai bridge IP public]

/interface bridge add name=serverbridge disabled=no /interface bridge port add interface=eth3-ADSL bridge=serverbridge /interface bridge port add interface=eth4-servers bridge=serverbridge

[edit] Pemberian IP Address

Ip address kita berikan pada interface gateway local dan bridge. Pemberian ip pada bridge interface tidak mutlak, pemberian ip ini hanya untukmemudahkan remote access dari luar.

/ip address print /ip address add address=172.168.0.3/40 interface=serverbridge disabled=no /ip address print /ip address add address=192.168.0.254/16 interface=eth2-lokal disabled=no /ip address print

Selanjutnya kita setting default gateway kita.

/ip route add gateway=172.168.0.3 /ip route print

Kemudian kita test ping ke gateway  /ping 222.124.23.41

[edit] Konfigurasi NAT (Network Address Translation)

NAT berfungsi untuk meneruskan paket dari ip local ke ip public (fungsi gateway router)

/ip firewall nat add chain=srcnat action=src-nat to-addresses=172.168.0.3 to-ports=0-65535 out-interface=serverbridge disabled=no /ip firewall nat add chain=dstnat action=dst-nat to-addresses=172.168.0.6 to-addresses=172.168.0.6 to-addresses=172.168.0.6 to-ports=2011 dst-port=80 in-interface=eth2-local disabled=no

[edit] setting DNS

/ip dns set primary-dns=172.168.0.6 allow-remoterequests=yes /ip dns set secondary-dns=202.134.1.10 allow-remoterequests=yes /ip dns print

Kemudian tes ping ke nama domain ex: google.com

Ok, untuk saat ini kita akan coba membuat web-proxy transparen dengan mikrotik. Seperti halnya membuat web-proxy dengan menggunakan linux, setelah kita membuat web-proxy kita akan memaksa mengarahkan port yang mau keluar harus melalui proxy.

Ok, kita akan mulai saja bagaimana langkah-langkahnya :

  1. Seperti biasa, kita persiapkan alat perang kita biasanya, u know what I mean (kopi ama rokok) :D
  2. Untuk konfigurasi dasar seperti setting IP Address, kita lanjutkan dari artikel sebelumnya. Jadi kita hanya tinggal menambahkan fungsi web proxy saja.
  3. Setelah kita masuk ke console dari mikrotik, kita mulai dengan membuat web-proxy itu sendiri.

    [admin@MikroTik] > ip web-proxy
    [admin@MikroTik] ip web-proxy> set enabled=yes
    [admin@MikroTik] ip web-proxy> set src-address=0.0.0.0
    [admin@MikroTik] ip web-proxy> set port=8080
    [admin@MikroTik] ip web-proxy> set hostname=proxy.infonesia.info //ganti dengan nama proxy anda
    [admin@MikroTik] ip web-proxy> set transparent-proxy=yes
    [admin@MikroTik] ip web-proxy> set parent-proxy=0.0.0.0:0
    [admin@MikroTik] ip web-proxy> set cache-administrator=web@infonesia.info //ganti dengan alamt email anda
    [admin@MikroTik] ip web-proxy> set max-object-size=4096KiB
    [admin@MikroTik] ip web-proxy> set cache-drive=system
    [admin@MikroTik] ip web-proxy> set max-cache-size=unlimited
    [admin@MikroTik] ip web-proxy> set max-ram-cache-size=unlimited

  4. Setelah langkah-langkah diatas selesai, kita akan coba forward paksa akses keluar menuju ke proxy dahulu dengan langkah-langkah sebagai berikut

    [admin@MikroTik] ip web-proxy> /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080
    [admin@MikroTik] ip web-proxy> /ip firewall nat add chain=dstnat protocol=tcp dst-port=3128 action=redirect to-ports=8080
    [admin@MikroTik] ip web-proxy> /ip firewall nat add chain=dstnat protocol=tcp dst-port=8080 action=redirect to-ports=8080

Ok, pembuatan proxy kita sudah selesai. Untuk mengecek apakah setup proxy  kita sudah benar, kita akan coba blokir akses untuk suatu situs. Untuk kali ini kita akan memakai contoh friendster.com untuk diblokir. Cara untuk memblokir situs sebagai berikut :

[admin@MikroTik] ip web-proxy> access add url=friendster.com method=any action=deny

Kemudian kita coba di komputer klien, dengan browser coba untuk mengakses situs friendster.com. Jika waktu membuka situs tersebut keluar seperti gambar di bawah ini, maka konfigurasi proxy anda berhasil. Jika masih bisa membuka halaman utama situs tersebut, maka konfigurasi anda masih salah. Coba trace kesalahan anda.

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s




%d blogger menyukai ini: